Simple Glyphs - Contours

Previous  Next

You can perform several operations on contours while in Contour mode.

Select contours

To select more than one contour, hold down the Shift key while selecting contours. Another way is to click on the workspace where no contours are and, while holding down the left mouse button, drag a rectangle around all contours you want to select simultaneously. Use the Ctrl-A shortcut to select all contours.

Resize selected contours

When you select one or more contours, a box with "resizing handles" shows up around the selected contour(s). Click and drag one of those resizing handles to change the size of the selected contour(s). By default the selected contour(s) remain proportional to the original size, as you resize it. Press the Shift key while you drag one of the resizing handles located at the corners to resize freely.

Move selected contours

To constrain a selection so it moves only horizontally or vertically, press Shift as you drag the selection. Press Alt to ignore the snap to grid and snap to guidelines features.

Duplicate selected contours

To copy selected contours to a new position, hold down the Ctrl key as you drag the selection. Hold the Alt key to ignore the snap to grid and snap to guidelines features. Hold down the Shift key to move only in vertical or horizontal direction. Any combination of these keys is allowed.

Rotate selected contours

You can rotate by first selecting a contour (or more) and then select it again (don't double-click). The little rectangles on the corners have changed into circles. These can be used to rotate the selected contour(s). The other four rectangles are used to skew the selection. To change the origin for the rotation you can move the little cross in the middle of your selection.

 

There are several ways to add outlines (contours) to a glyph:

Using the Freedraw Contours tool
Select the Add rectangle or Add ellipse button on the Drawing toolbar and place it on the Glyph Edit window.
Draw a new contour

First select Contour from the Insert menu. A left mouse click creates a point on the contour and a right mouse click creates a point off the contour for a b├ęzier curve. Creating points while holding down the Ctrl key generates straight lines (horizontal or vertical). After you have created your contour you press the Apply button.

Samples toolbar:

Drag and drop a glyph from the Samples toolbar into a Glyph Edit window.

Copy contours from other glyphs, even from other fonts and paste them. (These operations carried out in their respective Glyph Overview windows)
Import a stored vector or bitmap file of an image of a glyph into a Glyph Edit window using Import in the Tools menu.
Paste a Clipboard image of a glyph into the Glyph Edit window. The Clipboard image could be created in another application which has graphics editing capabilities e.g. a cropping function. This operation is performed using the Paste option in the Edit menu.